ステラリス終了後GPUのクロックが下がらない現象(未解決)

記事をシェアする

管理人です<(_ _)>

先日よりステラリスを終了してもGPUの温度が下がらず
グラフィックカードが高温になりっぱなしになる現象が発生して頭を抱えてます( ´Д`)

まだこれだという良い解決方法は見つかりませんが、
今までわかったことを今後のために書き残しておきたいと思います。

スポンサーリンク

どういう問題が起こっているのか

さっそく本題に入ります。

環境と平常時の状態について

Youtubeの動画をご覧の方は動画概要欄に私のPCスペックが書いてあるので
既にご存じの方もいらっしゃるかもしれませんが
状況を把握するためにあらためて環境を書くと、

【環境】
OS:Windows 7 64bit版
CPU:Intel Core i7 2600 3.4GHz
MB:ASUS P8 H67-V
GPU:MSI GTX 960 GAMING 2G
メモリ:DDR3 16G

となっています。

今回の問題でいちばん大事なのはグラフィックカードなので

MSI GTX 960 GAMING 2G

が一番ポイントになりそうですね。

こちらのグラボですがアイドル時というかゲームをやらない時は

  • 温度40℃以下
  • GPUメモリークロック405MHz

を常に保つようなそんなカードです。MSIは静かでよく冷えると思います(・ω・)

問題点と発生時期

まず起こっている問題ですが、

  1. ステラリスを終了してもグラフィックカードの温度が下がらない(50℃近くから下がらない)
  2. GPUパワーが20%超を常に保ち続ける。
  3. GPUのメモリークロックが3505MHzで固定され下がらない。

となります。

3つ挙げていますが、いちばん大事な事は
3.のGPUのメモリークロックが3505MHzほどで固定されていることではないか?
と考えています。ここが下がれば1と2は自然解決すると思います(・_・)

この現象に気がついたのは2017年10月の4週目、10/22~10/28の間です。
(たぶん25日の水曜だったかも)

それまであれやこれやで忙しくてなかなかゲームができなかったのですが、
ようやく時間が取れるようになったので新しいAARの作成に取り掛かろう~と色々Modを試しているときに気が付きました( ´Д`)

なおPCを起動後ステラリスをやらなければ、
先述の40℃以下、405MHzを保っています。

グラフィックカードの50℃ぐらいは故障にはならない状態ではありますが、
問題はそう言うことじゃなくて

今まで負担のかからない状態で使えていたのに急におかしくなってしまった。

という点だと思います。

取った対策

対策1 グラフィックドライバの入れ替え

問題が発生した10月の後半はGeForceのドライバ更新が何度かあった時期なので、ドライバを入れ替えたのが良くなかったのかなぁ?と考えました。

確かこの時期に立て続けにGeForceドライバの388.00と388.13の更新を行いました。
なので一旦GeForceのドライバをきれいに全削除→過去の安定版としてネット上で評価の高かった、バージョン385.69のドライバをインストールして問題が解決できているかを調査しました。

結果:問題は解決できず(-_-)

どうやらGeForceのドライバが原因ではなさそうな感じです。
(あくまで素人判断だけど・・・)

ただ一連のドライバ更新関係で気になったのが、388.0を入れている時点で高温張り付き状態になっていたので、その状態のまま388.13のドライバを入れてみました。

その時ドライバインストール中に、それまで何をやっても3505MHzから下がらなかったクロックがすっと通常の状態まで下がるのを目視で確認してます。

なのでクロックを下げるための何らかの働きかけ・命令がグラボに対して通らないわけでは無いのだろうと考えます。
(あんまりこの問題とは関係ないかもしれないけど(・_・))

対策2 MSIアフターバーナーによる手動クロックダウン

MSIのグラボなのでMSIアフターバーナーと相性は良いはずです。
(元々がMSIアフターバーナーは他社のグラボでも使うことができるツールです。)

そこでMSIアフターバーナーを使って3505MHzからクロックを下げて見ることにしました。

結果:下がりませんでした(-_-)

この時点でほぼ「お手上げ侍だワ」状態です。

対策3 PCの再起動

高温・高クロック張り付き状態が発見された後もPC起動直後にはグラフィックカードの温度もクロックも低いままです。

ですので問題が発生しているのを確認した上でPCの再起動を行いました。

結果:温度・クロックともにアイドル時と同じ状態に戻る

ということで、

現状、問題が発生していてもPCを再起動すれば直る

という状態です。

逆に言えば現象が発生した場合はPCを再起動しない限りは直らないわけですが・・・

現象の切り分け

今回の問題が果たしてステラリスのせいなのかを確認するためゲームを幾つか

起動→プレイ→また起動プレイ→他のゲームに移る

など負荷テストをやってみました。

行ったゲームは

  • ユーロトラックシミュレーター2(ETS2)
  • アメリカントラックシミュレーター(ATS)
  • Cties:Skylines
  • HoI4
  • The Last Remnant(ラストレムナント)
    ※ラストレムナントは非常に好きなゲームなので、いつか実況動画を作りたいですね(*´ω`*)
  • ステラリス

となります。どれも重たいゲームばかりです。

結果:ステラリスだけで問題が発生していました(-_-)

比較画像

正常時と問題時の画像を貼ってみます。

[正常時(アイドル時)の状態]

MSIアフターバーナー

CPUID

GPUメモリークロックが405MHzで安定しています。

[問題発生時(ステラリス終了後数分経ったもの)]

MSIアフターバーナー

CPUID

このようになっています。
たまたまステラリスだけで現象が発生しただけで、
私が持っていない他のゲームでも起こるのかもしれません。

がステラリスを起動→終了した場合は100%発生するんですよねえ。

なおこのステラリスはDLCは全て適用させていますが、
Modを全て外した状態でテストしています。

なのでパラド社の公式コンテンツのみで構成した状態なのに問題が起きていることになってしまいます・・・( ´Д`)ハフー

考察・まとめ

  • これまで問題が無かったのに急にGPUがおかしくなる現象が発生した。
  • ステラリス起動・終了で100%発生している。
  • 問題を解決するにはPC再起動で直る。
  • 他のゲームではゲームが終われば即座にアイドル時の数値に戻る。

という感じですね。

冒頭にも書いたけどこれでグラフィックカードが壊れる可能性は低いとは思いますが、
アイドル状態よりは負荷がかかっているわけなのであまり良いとも言えないと思います。

そしてステラリスで必ず発生しているのがよくない印象ですよねえ( ´Д`)

これってバージョン1.8からおかしくなってない?

以下は私が考えていることで、個人の考えなので正しいとは限りません(_ _;)

ですが、これってバージョン1.8以降でおかしくなったんじゃない?
って気がするんですよねぇ( ´Д`)

というのもバージョン1.6代の事までもう詳細には覚えてませんが、
以前はステラリスを終了してもこういったグラフィックカードの問題は私の知る範囲ではありませんでした。
普段からちょこちょこCPUIDで状態を見たりしますので・・・

そして私がバージョン1.8が怪しいと思ってる理由があります。
それは1.8以降の1.8、1.8.2、1.8.3のどの段階かは分かりませんが、

ステラリスの起動時の挙動が明らかに以前よりおかしくなってるんですよねえ。

それはSteamからにしろデスクトップショートカットからにしろ、
ステラリスを起動するとまずはランチャー(小ウィンドウ)が立ち上がりますよね。

ランチャーでModやDLCの調整をした後、ステラリス本体を起動するわけですが、
この本画面起動時にウインドウのフォーカスが変な方向に外れてしまってゲームウィンドウ(フルスクリーン表示でも)が数秒間行方不明になる現象が起きるようになってしまっています。

前はこんな挙動じゃありませんでした。
ランチャーからスタートに進めばステラリスのゲーム画面がスパッと最前面で立ち上がってきてそこからローディングが始まっていました。

このフォーカスがしばらく外れて行方不明になる現象が発生するようになってからGPUの問題が発生したというのが私の印象です。

フォーカス外れがGPUのクロック高止まりとどうつながるのか、私には技術的な事は分かりませんが、どうも時期が一致して怪しいと思うんですよね。

パラド社がこの問題を把握してるのかはちょっと分かりませんし、フォーラムをざっと見たところ該当する投稿は見つけられませんでした。

もしかしたら私だけの特殊な環境がなにか問題を起こしているのかもしれません( ´Д`)

とりあえず今できる対策としてはステラリスが終わったらPCを再起動したほうが良さそうです。

また色々探ってみて何か分かったらお知らせしたいと思いますm(_ _)m